Installation

System Requirements
Setting Up
Running

System Requirements

AnubisBot uses libraries which utilize some newer PHP stuff. Thus, you need a newer version of PHP (Sorry, but only PHP 7+ is supported because it's the only one DiscordPHP works with).

  • PHP >= 7.0.20

Setting Up

AnubisBot utilizes Composer, so you'll need it.

To create a new project for AnubisBot, execute the following:

$ composer create-project pazuzu156/anubisbot --prefer-dist

If you want the latest code base, use dev-develop. CAUTION dev-develop is the development branch, and thus is considered unstable. Only use it if you're fine with things breaking all the time ;)

$ composer create-project pazuzu156/anubisbot:dev-develop --stability=dev --prefer-dist

Running

From here, you should be set to running the default bot with all the built in commands. To run, execute the following:

$ php cli run